using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?=[^(]*\))";
string substitution = @"";
string input = @"Test123(45)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}