const regex = /\d+(?=[^(]*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?=[^(]*\\))', 'g')
const str = `Test123(45)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);