$re = '/\d+(?=[^(]*\))/';
$str = 'Test123(45)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;