using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name:\s(.*),\slocation:\s(.*),\sdescription:\s(.*),\sskills:\s(.*)";
string input = @"name: jo mamma, location: Atlanta, Georgia, description: He is a good boy, and he is pretty funny, skills: not much at all!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}