const regex = /name:\s(.*),\slocation:\s(.*),\sdescription:\s(.*),\sskills:\s(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name:\\s(.*),\\slocation:\\s(.*),\\sdescription:\\s(.*),\\sskills:\\s(.*)', '')
const str = `name: jo mamma, location: Atlanta, Georgia, description: He is a good boy, and he is pretty funny, skills: not much at all!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}