$re = '/name:\s(.*),\slocation:\s(.*),\sdescription:\s(.*),\sskills:\s(.*)/';
$str = 'name: jo mamma, location: Atlanta, Georgia, description: He is a good boy, and he is pretty funny, skills: not much at all!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);