using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{gop:include\s*name=[^\s]*\s*}";
string input = @"I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ{gop:include name='template'}{gop:include name=""tempe3late""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}