re = /{gop:include\s*name=[^\s]*\s*}/m
str = 'I\'m at Harrah\'s Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ{gop:include name=\'template\'}{gop:include name="tempe3late"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end