using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)Local time.*?(\d{2}:\d{2}:\d{2}\s+[AP]M)";
string input = @"Current time at \\\\gt2-dmsql1cst is 6/1/2015 11:59:49 AM
Local time (G
MT-05:00) at \\gt2-dmsql1cst is 6/1/2015 10:59:49 AM
The command comple
ted successfully.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}