import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)Local time.*?(\\d{2}:\\d{2}:\\d{2}\\s+[AP]M)";
final String string = "Current time at \\\\\\\\gt2-dmsql1cst is 6/1/2015 11:59:49 AM\n\n"
+ "Local time (G\n"
+ "MT-05:00) at \\\\gt2-dmsql1cst is 6/1/2015 10:59:49 AM\n\n"
+ "The command comple\n"
+ "ted successfully.\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}