$re = '/(?si)Local time.*?(\d{2}:\d{2}:\d{2}\s+[AP]M)/';
$str = 'Current time at \\\\\\\\gt2-dmsql1cst is 6/1/2015 11:59:49 AM
Local time (G
MT-05:00) at \\\\gt2-dmsql1cst is 6/1/2015 10:59:49 AM
The command comple
ted successfully.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);