const regex = /(?si)Local time.*?(\d{2}:\d{2}:\d{2}\s+[AP]M)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)Local time.*?(\\d{2}:\\d{2}:\\d{2}\\s+[AP]M)', 'g')
const str = `Current time at \\\\\\\\gt2-dmsql1cst is 6/1/2015 11:59:49 AM
Local time (G
MT-05:00) at \\\\gt2-dmsql1cst is 6/1/2015 10:59:49 AM
The command comple
ted successfully.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}