import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Html->script|cell|element|Html->css)\\(([^\\)]+)\\)";
final String string = "$this->element('element.ctp');\n"
+ "$this->cell('teste.ctp');\n"
+ "$this->Html->script([\n"
+ " 'teste.js'\n"
+ "]);\n"
+ "$this->Html->script([\n"
+ " 'teste.js',\n"
+ " 'teste2.js',\n"
+ "]);\n"
+ "$this->Html->script(['teste.js']);\n"
+ "$this->Html->script('teste.js');\n"
+ "$this->Html->css(['teste.css']);\n\n"
+ "--- trechos comentados, não deveria pegar\n"
+ "// $this->Html->css('teste.css');\n"
+ "/* ou comentário multi-linha\n"
+ "$this->Html->script('teste.js');\n"
+ "$this->Html->css(['teste.css']);\n"
+ "*/\n\n"
+ "--- chama função dentro, não retorna o \")\" da chamada\n"
+ "$this->Html->css(outraFuncaoQueRetornaOcss());\n\n"
+ "--- não cai na condição do lookbehind, a regex ignora\n"
+ "$this->whatever('teste');\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}