import Foundation
let pattern = #"(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$this->element('element.ctp');
$this->cell('teste.ctp');
$this->Html->script([
'teste.js'
]);
$this->Html->script([
'teste.js',
'teste2.js',
]);
$this->Html->script(['teste.js']);
$this->Html->script('teste.js');
$this->Html->css(['teste.css']);
--- trechos comentados, não deveria pegar
// $this->Html->css('teste.css');
/* ou comentário multi-linha
$this->Html->script('teste.js');
$this->Html->css(['teste.css']);
*/
--- chama função dentro, não retorna o ")" da chamada
$this->Html->css(outraFuncaoQueRetornaOcss());
--- não cai na condição do lookbehind, a regex ignora
$this->whatever('teste');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)