const regex = /(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Html->script|cell|element|Html->css)\\(([^\\)]+)\\)', 'gm')
const str = `\$this->element('element.ctp');
\$this->cell('teste.ctp');
\$this->Html->script([
'teste.js'
]);
\$this->Html->script([
'teste.js',
'teste2.js',
]);
\$this->Html->script(['teste.js']);
\$this->Html->script('teste.js');
\$this->Html->css(['teste.css']);
--- trechos comentados, não deveria pegar
// \$this->Html->css('teste.css');
/* ou comentário multi-linha
\$this->Html->script('teste.js');
\$this->Html->css(['teste.css']);
*/
--- chama função dentro, não retorna o ")" da chamada
\$this->Html->css(outraFuncaoQueRetornaOcss());
--- não cai na condição do lookbehind, a regex ignora
\$this->whatever('teste');
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}