re = /(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)/m
str = '$this->element(\'element.ctp\');
$this->cell(\'teste.ctp\');
$this->Html->script([
\'teste.js\'
]);
$this->Html->script([
\'teste.js\',
\'teste2.js\',
]);
$this->Html->script([\'teste.js\']);
$this->Html->script(\'teste.js\');
$this->Html->css([\'teste.css\']);
--- trechos comentados, não deveria pegar
// $this->Html->css(\'teste.css\');
/* ou comentário multi-linha
$this->Html->script(\'teste.js\');
$this->Html->css([\'teste.css\']);
*/
--- chama função dentro, não retorna o ")" da chamada
$this->Html->css(outraFuncaoQueRetornaOcss());
--- não cai na condição do lookbehind, a regex ignora
$this->whatever(\'teste\');
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end