const regex = /\|*Admin\|*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|*Admin\\|*', 'gim')
const str = `1H|\\^&|||ARCHITECT^8.10^F3453010030^H1P1O1R1C1Q1L1|||Admin||||P|1|20150511083525
1D`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);