re = /\|*Admin\|*/im
str = '1H|\\^&|||ARCHITECT^8.10^F3453010030^H1P1O1R1C1Q1L1|||Admin||||P|1|20150511083525
1D'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result