using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0*([1-9]\d{0,5})-)?0*([1-9]\d{0,9})$";
string input = @"0123419-000001234567890";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}