package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0*([1-9]\d{0,5})-)?0*([1-9]\d{0,9})$`)
var str = `0123419-000001234567890`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}