$re = '/^(0*([1-9]\d{0,5})-)?0*([1-9]\d{0,9})$/';
$str = '0123419-000001234567890';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);