import re
regex = re.compile(r"^(0*([1-9]\d{0,5})-)?0*([1-9]\d{0,9})$")
test_str = "0123419-000001234567890"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")