#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "["](""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?["]"
Local $sString = "Year,Make,Model,Description,Price" & @CRLF & _
"1997,Ford,E350,"ac, abs, moon",3000.00" & @CRLF & _
"1999,Chevy,"Venture ""Extended Edition""","",4900.00" & @CRLF & _
"1999,Chevy,"Venture ""Extended Edition, Very Large""",,5000.00" & @CRLF & _
"1996,Jeep,Grand Cherokee,"MUST SELL!" & @CRLF & _
"air, moon roof, loaded",4799.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")