import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\"](\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?[\"]";
final String string = "Year,Make,Model,Description,Price\n"
+ "1997,Ford,E350,\"ac, abs, moon\",3000.00\n"
+ "1999,Chevy,\"Venture \"\"Extended Edition\"\"\",\"\",4900.00\n"
+ "1999,Chevy,\"Venture \"\"Extended Edition, Very Large\"\"\",,5000.00\n"
+ "1996,Jeep,Grand Cherokee,\"MUST SELL!\n"
+ "air, moon roof, loaded\",4799.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}