# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\"](\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?(\"\"[^\"]*\"\"|[^\",]*)[,]?[\"]"
test_str = ("Year,Make,Model,Description,Price\n"
"1997,Ford,E350,\"ac, abs, moon\",3000.00\n"
"1999,Chevy,\"Venture \"\"Extended Edition\"\"\",\"\",4900.00\n"
"1999,Chevy,\"Venture \"\"Extended Edition, Very Large\"\"\",,5000.00\n"
"1996,Jeep,Grand Cherokee,\"MUST SELL!\n"
"air, moon roof, loaded\",4799.00")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.