package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`["](""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?(""[^"]*""|[^",]*)[,]?["]`)
var str = `Year,Make,Model,Description,Price
1997,Ford,E350,"ac, abs, moon",3000.00
1999,Chevy,"Venture ""Extended Edition""","",4900.00
1999,Chevy,"Venture ""Extended Edition, Very Large""",,5000.00
1996,Jeep,Grand Cherokee,"MUST SELL!
air, moon roof, loaded",4799.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}