using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)";
string substitution = @"$1¿$2$3";
string input = @"Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}