re = /(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)/
str = 'Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?'
subst = '$1¿$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result