using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/h2>(.*?)<";
string input = @"<h2>my title here</h2>Lorem ipsum dolor sit amet<h2>my title here</h2>consectetur adipisicing elit quod tempora";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}