// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<\/h2>(.*?)<").unwrap();
let string = "<h2>my title here</h2>Lorem ipsum dolor sit amet<h2>my title here</h2>consectetur adipisicing elit quod tempora";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}