package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/h2>(.*?)<`)
var str = `<h2>my title here</h2>Lorem ipsum dolor sit amet<h2>my title here</h2>consectetur adipisicing elit quod tempora`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}