package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\%\w+\((?<First>\d+)\)]*\%>(?<Data>.+?)<\%\w+\((?<Second>\d+)\)]*\%>`)
var str = `<%VariableA(018)%>{:13:}<%VariableB(012)%>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}