re = /<\%\w+\((?<First>\d+)\)]*\%>(?<Data>.+?)<\%\w+\((?<Second>\d+)\)]*\%>/
str = '<%VariableA(018)%>{:13:}<%VariableB(012)%>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end