$re = '/<\%\w+\((?<First>\d+)\)]*\%>(?<Data>.+?)<\%\w+\((?<Second>\d+)\)]*\%>/';
$str = '<%VariableA(018)%>{:13:}<%VariableB(012)%>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);