const regex = /<\%\w+\((?<First>\d+)\)]*\%>(?<Data>.+?)<\%\w+\((?<Second>\d+)\)]*\%>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\%\\w+\\((?<First>\\d+)\\)]*\\%>(?<Data>.+?)<\\%\\w+\\((?<Second>\\d+)\\)]*\\%>', '')
const str = `<%VariableA(018)%>{:13:}<%VariableB(012)%>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}