use strict;
my $str = '*aaba*';
my $regex = qr@(\*).*(\*)@p;
my $subst = '<span style="color:blue;">$0</span>';
my $result = $str =~ s@$regex@$subst@r;
print "The result of the substitution is' $result\n";