$re = '@(\*).*(\*)@';
$str = '*aaba*';
$subst = "<span style=\"color:blue;\">$0</span>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;