re = /(\*).*(\*)/
str = '*aaba*'
subst = '<span style="color:blue;">$0</span>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result