import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([a-z\\-\\d]+(\\/[a-z\\-\\d]+)?)\\/(apartments-for-rent|apartamentos-alquiler|homes-for-rent|casas-alquiler(.*))?\\/map";
final String string = "/cincinnati/map\n"
+ "/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}