re = /\/([a-z\-\d]+(\/[a-z\-\d]+)?)\/(apartments-for-rent|apartamentos-alquiler|homes-for-rent|casas-alquiler(.*))?\/map/
str = '/cincinnati/map
/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end