// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/([a-z\-\d]+(\/[a-z\-\d]+)?)\/(apartments-for-rent|apartamentos-alquiler|homes-for-rent|casas-alquiler(.*))?\/map").unwrap();
let string = "/cincinnati/map
/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}