import re
regex = re.compile(r"\/([a-z\-\d]+(\/[a-z\-\d]+)?)\/(apartments-for-rent|apartamentos-alquiler|homes-for-rent|casas-alquiler(.*))?\/map")
test_str = ("/cincinnati/map\n"
"/")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")