#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?=\w+)[\w|-]+.fa)"
Local $sString = "chr5fa 153584000fa 15359999fas9 D160||||73_orphan_reads|||.fa;709[F18|R11] unkn 1 unkn 2509" & @CRLF & _
"" & @CRLF & _
"chr7 153764000 153775999 D16073_orphan_reads.fa;710[F9fa|R21fa],14892_orphan_reads.fa;229[F19|R16] unkn 1 unkn 2510" & @CRLF & _
"" & @CRLF & _
"chr3 127848000 127871999 B15971_orphan_reads.fa;172[F35|R6],D16157-14_orphan_reads.fa;183[F6|R13],14892_orphan_reads.fa;229[F19|R16],USP19283_orphan_reads.fa;336[F10|R6],D15927-14_orphan_reads.fa;176[F11|R10],1007,1007 46 1007 1658" & @CRLF & _
"" & @CRLF & _
"(...)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")