import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=\\w+)[\\w|-]+.fa)";
final String string = "chr5fa 153584000fa 15359999fas9 D160||||73_orphan_reads|||.fa;709[F18|R11] unkn 1 unkn 2509\n\n"
+ "chr7 153764000 153775999 D16073_orphan_reads.fa;710[F9fa|R21fa],14892_orphan_reads.fa;229[F19|R16] unkn 1 unkn 2510\n\n"
+ "chr3 127848000 127871999 B15971_orphan_reads.fa;172[F35|R6],D16157-14_orphan_reads.fa;183[F6|R13],14892_orphan_reads.fa;229[F19|R16],USP19283_orphan_reads.fa;336[F10|R6],D15927-14_orphan_reads.fa;176[F11|R10],1007,1007 46 1007 1658\n\n"
+ "(...)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}