using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=\w+)[\w|-]+.fa)";
string input = @"chr5fa 153584000fa 15359999fas9 D160||||73_orphan_reads|||.fa;709[F18|R11] unkn 1 unkn 2509
chr7 153764000 153775999 D16073_orphan_reads.fa;710[F9fa|R21fa],14892_orphan_reads.fa;229[F19|R16] unkn 1 unkn 2510
chr3 127848000 127871999 B15971_orphan_reads.fa;172[F35|R6],D16157-14_orphan_reads.fa;183[F6|R13],14892_orphan_reads.fa;229[F19|R16],USP19283_orphan_reads.fa;336[F10|R6],D15927-14_orphan_reads.fa;176[F11|R10],1007,1007 46 1007 1658
(...)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}