using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!,)\\""(?!,)";
string input = @"user,\""Fall Out Boy\"",\""\""The Take Over, The Breaks Over\""\"",0,2010,4,17,7,11,37
user,\""Gare du Nord\"",\""I Want Love 12\"" Remix\"",0,2011,6,12,19,32,33";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}