$re = '/(?<!,)\\\\"(?!,)/m';
$str = 'user,\\"Fall Out Boy\\",\\"\\"The Take Over, The Breaks Over\\"\\",0,2010,4,17,7,11,37
user,\\"Gare du Nord\\",\\"I Want Love 12\\" Remix\\",0,2011,6,12,19,32,33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);