use strict;
my $str = 'user,\\"Fall Out Boy\\",\\"\\"The Take Over, The Breaks Over\\"\\",0,2010,4,17,7,11,37
user,\\"Gare du Nord\\",\\"I Want Love 12\\" Remix\\",0,2011,6,12,19,32,33';
my $regex = qr/(?<!,)\\"(?!,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}