import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!,)\\\\\"(?!,)";
final String string = "user,\\\"Fall Out Boy\\\",\\\"\\\"The Take Over, The Breaks Over\\\"\\\",0,2010,4,17,7,11,37\n"
+ "user,\\\"Gare du Nord\\\",\\\"I Want Love 12\\\" Remix\\\",0,2011,6,12,19,32,33";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}