using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})";
string input = @"netstat -anob
netstat -ano
netstat -anob
netstat -ano
netstat /anob
netstat /ano
netstat /anob
netstat /ano
netstat/anob
netstat/ano
netstat /anob
netstat /ano
netstat -a
netstat -an
netstat /a
netstat /an
netstat /ona
netstat /bona
netstat /nob
netstat /noba
netstat /onab
netstat /noba
netstat /abon
netstat /abn
netstat /anb
netstat-anob
netstat-ano
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}